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Error “Unable to connect to data source with the supplied credentials, or no credentials provided” Connecting Live or Refreshing a Dropbox Extract


Published: 01 Apr 2022
Last Modified Date: 04 Apr 2022

Issue

When attempting to access a live data source or refresh an extract with Dropbox after 3-5 hours of successful connections, the following error occurs:
 
Unable to connect to data source with the supplied credentials, or no credentials provided. Tableau needs an unexpired OAuth refresh token to connect to the data. Ask your database administrator to issue a refresh token, then try again. You must log in to Dropbox to perform this request.

Environment

  • Tableau Online
  • Tableau Server
  • Dropbox

Resolution

To workaround the issue, manually delete and re-add the saved credentials under your account settings. See Manage Saved Credentials for Data Connections
 for more information.
Note: If you have an extract scheduled to run hourly, you would need to manually delete and re-add your credentials every few hours in order for jobs to succeed. 

Cause

DropBox changed its OAuth policy to use short-lived tokens. 
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