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Error “Unable to connect to data source with the supplied credentials, or no credentials provided” Connecting Live or Refreshing a OneDrive (deprecated), OneDrive and SharePoint Online, Dropbox, or Google Drive extract


Published: 30 Sep 2022
Last Modified Date: 13 Oct 2022

Issue

When attempting to access a live data source or refresh an extract with OneDrive (deprecated), OneDrive and SharePoint Online, Dropbox, or Google Drive after previously of successful connections, the following error occurs:
 
Unable to connect to data source with the supplied credentials, or no credentials provided. Tableau needs an unexpired OAuth refresh token to connect to the data. Ask your database administrator to issue a refresh token, then try again. You must log in to Dropbox to perform this request.

Environment

  • Tableau Cloud
  • Tableau Server 2022.3
  • OneDrive (deprecated)
  • OneDrive and SharePoint Online
  • Dropbox
  • Google Drive

Resolution

To correct the issue, sign in to the data source when prompted or manually delete and re-add the saved credentials under your account settings. Under normal circumstances, this should be a one-time correction. See Manage Saved Credentials for Data Connections for more information.

Cause

In Tableau 2022.3, back-end changes were made to OAuth handling that require reauthenticating to these data sources.
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