KNOWLEDGE BASE

Error "This command is not supported in the prepared statement protocol yet" When Connecting to MongoDB


Published: 29 Jul 2021
Last Modified Date: 08 Dec 2021

Issue

When connecting Tableau Desktop to a MongoDB BI Connector, the following error may occur:

[MySQL][ODBC 8.0(w) Driver][mysqld-5.7.12 mongosqld v2.14.3]This command is not supported in the prepared statement protocol yet

Environment

  • Tableau Desktop
  • Tableau Server
  • MongoDB BI Connector
  • Windows

Cause

Some of the latest MySQL ODBC driver versions (later than 8.0.23) are not compatible with the MongoDB BI Connector.
Did this article resolve the issue?