KNOWLEDGE BASE

Error "There is no active connection to the data source" Occurs When Using Tableau Data Extract Command-Line to Refresh Published Data Source


Published: 24 Jun 2022
Last Modified Date: 27 Jun 2022

Issue

When using the command line [tableau refreshextract] to refresh the published data source from the local PC, the below error occurs in Windows Prompt / Terminal and could not finish the refresh.

"There is no active connection to the data source."

Environment

  • Tableau Desktop
  • Tableau Server
  • Excel
  • CSV

Resolution

Please change the data source to a single-connection data source.

For example, if you use local-file data, please use one kind of file (Excel, CSV, etc.). Mixing multiple files as a data source will cause this error.
If you connect to a database, please use one type of database (e.g. Oracle, PostgreSQL, etc.)

 

Cause

This is by design.
You can use the Tableau Data Extract Command-Line to refresh single-connection data sources only. It does not work for multi-connection data sources.
 
Did this article resolve the issue?