KNOWLEDGE BASE

Error "The view snapshot in this email could not be properly rendered" in Subscription Email Using Live Connections


Published: 14 Feb 2019
Last Modified Date: 20 Feb 2019

Issue

When receiving subscriptions from workbooks which use live connections, the following error occurs: 
 
The view snapshot in this email could not be properly rendered. To see the view online go to...
 
Also, the Background Tasks for Non Extracts admin view may show an error similar to the following for the job: 
 
Subscription Id [x] for User [Email Address] Created by [Email Address] with Subject [x]: 1 of 1 views failed."
 
The Tableau Online logs may show the following error: 
 
The query limit resource limit (2700 seconds) was exceeded

Environment

  • Tableau Online
  • Subscriptions
  • Live Connections

Resolution

Work with your database administrator to investigate connectivity issues with live connections. 

To workaround the issue, try using extracts rather than live connections. See Extract Your Data for more information. 
 

Cause

Queries to the database are not completing, and Tableau Online cancels the job after a 45 minute timeout.
 
Did this article resolve the issue?