KNOWLEDGE BASE

Error "The user [...] could not be added because you do not have access to the domain specified." When Adding Users from Active Directory


Published: 04 Jun 2015
Last Modified Date: 27 Jul 2020

Issue

When adding users from the active directory, the following error might occur:
"The user [...] could not be added because you do not have access to the domain specified."
 
Additionally, the following error can be found in the vizportal log:
"Exception raised by call target for key [affected username]: Invalid Credentials (errorCode=100049)."

Environment

Tableau Server
Windows

Resolution

Work with the Tableau Server Administrator to stop Tableau Server, re-entering the Run As User password, and starting Tableau Server. Once done, consult with your Active directory administrator to make sure the Tableau Server Run As User has access to query the AD controller.

For Tableau Server 2018.1.X and Earlier (pre-TSM versions):
  1. Open an elevated command prompt, and navigate to the “bin” folder located in the Tableau Server directory.
    • For example if Tableau Server is installed in the default location, the directory will be: C:\Program Files\Tableau\Tableau Server\<version>\bin
  2. Type the following command to stop Tableau Server: tabadmin stop
  3. Please open Configure Tableau Server and re-enter the Run As User password. 
    • From the start menu, type "Configure Tableau Server", and right click the program to open it as a  Window Administrator.
    • Type the Run As user password and click "Ok" to save.
  4. Type the following command to start Tableau Server: tabadmin start

For Tableau Server 2018.2.X and Later (TSM versions):
  1. Open an elevated command prompt
  2. Type the following command to stop Tableau Server: tsm stop
  3. Update the Run as Service account using the information in the article below 
  4. Type the following command to start Tableau Server: tsm start

Cause

Tableau Server Run As User password may have changed or does not have access to the active directory to add users.
Did this article resolve the issue?