KNOWLEDGE BASE

Error "The requested licensing operation failed with error code '106'" Deactivating Product Key on Tableau Server Linux Container


Published: 18 May 2023
Last Modified Date: 30 May 2023

Issue

When trying to deactivate a product key on Tableau Server installed in a Linux container, the following errors will occur:
 
The requested licensing operation failed with error code '106':
TABLEAU_ERROR_LICENSING_ACTIVATION_INVALID_KEY

Environment

Tableau Server running in a Linux container environment.

Resolution

You can remove product key(s) that were activated using Server ATR when you want to reclaim license capacity from one Tableau Server installation and use it on another.  The following procedure removes all product keys from the installation.

1. Log in to the container:
ssh -i <pemfile.pem> fqdn of the machine
sudo docker ps -a
sudo docker exec -it <container_id> bash       

2. On the initial node, open a command prompt as an Administrator, and perform the following steps.
3. Stop the Administration Controller Manager (tabadmincongtroller):

supervisorctl -c $(DATA_DIR)/supervisord/supervisord.conf stop tabadmincontroller_0
4. Use the following atrdiag command to view the activated product keys and locate the value of the UUID:

./atrdiag -product "Tableau Server" -container

5. Copy the UUID field from the top of the atrdiag output to delete the ATR activation containing all activated product keys:

 ./atrdiag -deleteATR <UUID> -product "Tableau Server" -container

Note: It is not currently possible to remove an individual product key from the ATR lease with this method.

6. Log a Technical Support case to release the ATR activation on the Tableau License Server to avoid a maximum activation error.
7. Start the Administration Controller Manager (tabadmincontroller) if it isn't already running:

supervisorctl -c $(DATA_DIR)/supervisord/supervisord.conf start
tabadmincontroller_0

8. Activate a new set of product keys.
9. Restart Tableau Server.


 

Cause

The Tableau Development Team is investigating the issue under Salesforce Known Issue Reference ID W-12824953.

Additional Information

Review the ATR duration value to understand when the previous activation capacity will be available by reviewing this information.
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