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Error "The product key <key> has already been activated" Activating Tableau Server


Published: 26 Jun 2020
Last Modified Date: 21 Jan 2021

Issue

When attempting to activate a product key on Tableau Server, the following error occurs:

The product key <key> has already been activated
 

 

Environment

Tableau Server  2020.1 and newer versions

Resolution

If the key is activated and no action needs to occur:

Run TSM Licenses list command or review the keys in the TSM UI. For more information, see View Server Licenses.  If the product key does display, it will not be possible to activate the key again.  No further action is necessary as long as Tableau Server has been restarted since the key(s) were activated.

If the key does not match the Tableau Customer Portal but has an updated expiration date:

 After running TSM Licenses list command or viewing keys in the TSM UI, the product key is not updated to match the key listed in the Tableau Customer Portal but the subscription term expiration date does match the Tableau Customer Portal. No further action is needed.

If the Tableau Server is not able to read the product key stored in memory and the key is not listed in TSM:
  1. Open a command prompt from the initial node 
  2. Navigate to the Tableau Server bin directory, located by default at:
    Linux: /opt/tableau/tableau_server/packages/bin.<version_code>/
    Windows: \Program Files\Tableau\Tableau Server\packages\bin.version_code

  • Run the following commands one at a time:  
    Note: these steps will stop the Tableau Server and cause down time.
    tsm stop
    ./lmreread  (linux) or lmreread (Windows)
    tsm start
    tsm status -v

Cause

This behavior can be caused by one of the following: 

The Tableau Server product key is already activated and up to date but there is a mismatch between the product key listed in the Tableau Customer Portal and the product key listed on the Tableau Server.  This mismatch occurs when the subscription end date has not yet occurred but the new product key with the new subscription term is already refreshed and stored on Tableau Server.  The new key will start to show once the previous product key has expired. 
Note:  If the expiration date is at the highest level and matches the Tableau Customer Portal, there is no further action needed.

OR 

The Tableau Server is unable to access or read the area of memory where the product key is stored.   When this scenario occurs,  the product key is typically not visible when viewing keys using TSM.

Additional Information

Further understanding of why the Tableau Customer Portal and the Tableau Server product keys do not match can be found in the Tableau Community Blog.
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