KNOWLEDGE BASE

Errors: "FLEXNet licensing service is not present" or "Function flxActAppActivationSend returned error (0,0,0)" Activating on Mac


Published: 19 Jun 2014
Last Modified Date: 06 Mar 2023

Issue

When you try to activate a product key on Tableau Desktop on the Mac (not using LBLM), one of the following errors might occur:
 
The FLEXNet licensing service is not present on the system.

or
Function flxActAppActivationSend
returned error (0,0,0)
LM_TS error 0

Environment

  • Tableau Desktop 
  • OS X
  • Product key activation and not using LBLM (sign in to a server) to activate

Resolution

Option 1: Tableau Desktop 2019.3 and later versions

Perform the following to attempt to have the FLEXnet folder rebuilt.

  1. Close all instances of Tableau Desktop.
  2. From the Mac OS X desktop, hit Command+Shift+G.
  3. In the Go to Folder dialog, enter: /Library/Preferences/FLEXnet Publisher/
  4. Rename the FLEXnet folder by adding '_backup'.
  5. Start Tableau Desktop and activate your product key.
If trying to force the FLEXnet folder to be re-created does not succeed, please reinstall Tableau Desktop.  If still unable to get activation to succeed, please create a ticket with Tableau Technical Support.

Option 2: Tableau Desktop 2019.2 and earlier versions

On the computer running Tableau Desktop, manually install the FlexNet licensing components.
  1. In Finder, click Applications.
  2. Hold down the Control key, click Tableau, and then select Show Package Contents.
  3. Double-click Contents, double-click Installers, and then double-click Tableau FLEXNET.pkg.
  4. Follow the instructions in the installation wizard and use the default options.
If Tableau Desktop is installed on a non-default, or secondary volume, manually move the FNPLicensingService to the Root Library directory.
  1. In Finder, locate the FNPLicensingService file located in the "/Library/Application Support/FLEXnet Publisher/Service/11.16.2/" folder on the same volume Tableau Desktop is installed on.
  2. Copy the FNPLicensingService into the system root library and create the necessary folders: /Library/Application Support/FLEXnet Publisher/Service/11.16.2/
  3. Once that file is placed properly, launch and activate Tableau Desktop.

Cause

Either The FLEXNet package was not installed or is unreadable by the computer running Tableau Desktop, or Tableau Desktop was installed to a non-default volume.
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