BASE DE CONOCIMIENTO

Errores: "El servicio de licencia de FLEXNet no está presente" o "La función flxActAppActivationSend devolvió el error (0,0,0)" durante la activación en Mac


Publicado: 19 Jun 2014
Fecha de la última modificación: 03 Apr 2023

Problema

Cuando intente activar una clave de producto en Tableau Desktop en un equipo Mac (sin utilizar LBLM), es posible que se produzca uno de los errores siguientes:
 
El servicio de licencia FLEXNet no está presente en el sistema.

O bien
Function flxActAppActivationSend
returned error (0,0,0)
LM_TS error 0 (La función flxActAppActivationSend devolvió el error [0,0,0] LM_TS error 0)

Entorno

  • Tableau Desktop 
  • OS X
  • Activación de la clave de producto sin utilizar LBLM (iniciar sesión en un servidor) para activar

Solución

Opción 1: para Tableau Desktop 2019.3 y versiones posteriores

Ejecute lo siguiente para intentar reconstruir la carpeta FLEXnet.

  1. Cierre todas las instancias de Tableau Desktop.
  2. En la versión de escritorio de Mac OS X, presione Comando+Mayús+G.
  3. En el cuadro de diálogo Ir a la carpeta, escriba /Library/Preferences/FLEXnet Publisher/.
  4. Cambie el nombre de la carpeta FLEXnet agregando "_backup".
  5. Inicie Tableau Desktop y active la clave de producto.
Si el intento de forzar la recreación de la carpeta FLEXnet no tiene éxito, vuelva a instalar Tableau Desktop.  Si todavía no puede realizar la activación con éxito, cree un ticket con el Soporte técnico de Tableau.

Opción 2: para Tableau Desktop 2019.2 y versiones anteriores

En el equipo en el que se ejecuta Tableau Desktop, instale manualmente los componentes de licencia de FlexNet.
  1. En el Finder, haga clic en Aplicaciones.
  2. Mantenga presionada la tecla Control, haga clic en Tableau y, a continuación, seleccione Mostrar contenido del paquete.
  3. Haga doble clic en Contenido, en Instaladores y, finalmente, en Tableau FLEXNET.pkg.
  4. Siga las instrucciones del asistente de instalación y utilice las opciones predeterminadas.
Si Tableau Desktop se instaló en un volumen secundario no predeterminado, mueva manualmente FNPLicensingService al directorio de la biblioteca raíz.
  1. En Finder, busque el archivo FNPLicensingService ubicado en la carpeta "/Library/Application Support/FLEXnet Publisher/Service/11.16.2/" en el mismo volumen donde se instaló Tableau Desktop.
  2. Copie FNPLicensingService en la biblioteca raíz del sistema y cree las carpetas necesarias: /Library/Application Support/FLEXnet Publisher/Service/11.16.2/
  3. Una vez colocado correctamente ese archivo, inicie y active Tableau Desktop.

Causa

No se instaló el paquete FLEXNet, el equipo donde se ejecuta Tableau Desktop no puede leer el paquete o Tableau Desktop se instaló en un volumen no predeterminado.
¿Fue de ayuda este artículo para resolver el problema?