KNOWLEDGE BASE

Fehler: "FLEXNet-Lizenzierungsdienst nicht vorhanden" oder "Funktion flxActAppActivationSend hat einen Fehler zurückgegeben (0,0,0)" beim Aktivieren auf einem Mac


Veröffentlicht: 19 Jun 2014
Zuletzt geändert am: 03 Apr 2023

Problem

Wenn Sie versuchen, einen Produktschlüssel in Tableau Desktop auf dem Mac (ohne LBLM) zu aktivieren, tritt möglicherweise einer der folgenden Fehler auf:
 
The FLEXNet licensing service is not present on the system. (Der FLEXNet Licensing Service ist auf Ihrem System nicht vorhanden.)

oder
Function flxActAppActivationSend
returned error (0,0,0)
LM_TS error 0

Umgebung

  • Tableau Desktop 
  • OS X
  • Produktschlüssel-Aktivierung und keine Verwendung von LBLM (Anmeldung bei einem Server) zur Aktivierung

Lösung

Option 1: Tableau Desktop 2019.3 und spätere Versionen

Führen Sie folgende Schritte aus, um zu versuchen, den FLEXnet-Ordner neu anzulegen.

  1. Schließen Sie alle Instanzen von Tableau Desktop.
  2. Drücken Sie auf dem Schreibtisch in Mac OS X die Tastenkombination Befehl+Umschalt+G.
  3. Geben Sie im Dialog Gehe zu Ordner Folgendes ein: /Library/Preferences/FLEXnet Publisher/
  4. Benennen Sie den Ordner "FLEXnet" um, indem Sie "_backup" anfügen.
  5. Starten Sie Tableau Desktop und aktivieren Sie Ihren Produktschlüssel.
Wenn der Versuch, die Neuerstellung des FLEXnet-Ordners zu erzwingen, nicht erfolgreich ist, installieren Sie Tableau Desktop neu.  Wenn die Aktivierung weiterhin nicht erfolgreich ist, erstellen Sie ein Ticket beim technischen Support von Tableau.

Option 2: Tableau Desktop 2019.2 und Vorgängerversionen

Installieren Sie die FlexNet-Lizenzierungskomponenten manuell auf dem Computer, auf dem Tableau Desktop ausgeführt wird.
  1. Klicken Sie im Finder auf Anwendungen (Applications).
  2. Halten Sie die Ctrl-Taste gedrückt, klicken Sie auf Tableau und wählen Sie die Option Paketinhalt anzeigen (Show Package Contents) aus.
  3. Doppelklicken Sie nacheinander auf Inhalt (Contents), auf Installationsprogramme (Installers) und auf Tableau FLEXNET.pkg.
  4. Befolgen Sie die Anweisungen im Installationsassistenten und übernehmen Sie die Standardeinstellungen.
Wenn Tableau Desktop auf einem nicht standardmäßigen oder sekundären Volume installiert wird, verschieben Sie die Datei "FNPLicensingService" in das Stammbibliothek-Verzeichnis.
  1. Suchen Sie im Finder die Datei "FNPLicensingService" im Ordner "/Library/Application Support/FLEXnet Publisher/Service/11.16.2/" auf demselben Volume, auf dem Tableau Desktop installiert ist.
  2. Kopieren Sie die Datei "FNPLicensingService" in die System-Stammbibliothek und erstellen Sie die erforderlichen Ordner: /Library/Application Support/FLEXnet Publisher/Service/11.16.2/
  3. Nachdem die Datei ordnungsgemäß abgelegt wurde, starten und aktivieren Sie Tableau Desktop.

Ursache

Entweder wurde das FLEXNet-Paket nicht installiert oder kann von dem Computer, auf dem Tableau Desktop ausgeführt wird, nicht gelesen werden oder Tableau Desktop wurde auf einem nicht standardmäßigen Volume installiert.
Hat dieser Artikel das Problem gelöst?