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Error "The filename, directory name, or volume label syntax is incorrect" After Failure of Backup


Published: 17 May 2019
Last Modified Date: 20 May 2019

Issue

After a backup failure, the Backuprestore and tabadminagent logs will show the following error message:

Command prompt shows:

>tsm maintenance backup -f Backupfile
[...]
53% - Backing up object storage data failed.
[...]
An error occurred on the server generating the backup.

Backuprestore.log

[...] : ERROR com.tableausoftware.backuprestore.BackupRestoreServiceHandler - Error calling dataEngineBackup
org.apache.thrift.transport.TTransportException


Tabadminagent log

[...] : ERROR org.apache.thrift.server.TThreadPoolServer - Error occurred during processing of message.
java.lang.RuntimeException: org.apache.thrift.TException: java.io.IOException: The filename, directory name, or volume label syntax is incorrect


Additionally, the above errors might occur if the following scenarios occur:

  • Multi-node Tableau server
  • Filestore is not configured on tabadmincontroller node (Typically Initial node)  
  • Published extract datasource has 30+ long name and contains non-ascii characters, such as Japanese, Chinese, etc. Datasouce name example: Sample - Superstore (2) (ローカル コピー)

Environment

Tableau Server 2018.2.0 to 2018.2.8, 2018.3.0 to 2018.3.5 and 2019.1.0 to 2019.1.2

Resolution

Option 1

Upgrade to Tableau Server 2018.2.9, 2018.3.6, 2019.1.3 or a newer version. Click here for downloads of current and previous versions of Tableau Server: Tableau Server Downloads and Release Notes. For more information on current releases, see Upgrade Tableau Server and Server Upgrade.
 

Option 2

The Tabadminagent debug log will indicate which datasource causes the problem.
  • Delete the published extract datasource that has 30+ long name and contains non-ascii characters name from Tableau server Web UI
  • After 1 hour, confirm datasource is removed from \Tableau Server\data\tabsvc\dataengine\extract folder
  • Make sure the delete datasource name does not exist under the Dataengine folder
    • You can use tree command to confirm datasource name, for example:
      • cd C:\ProgramData\Tableau\Tableau Server\data\tabsvc\dataengine\extract
      • tree /a /f ​​​​

Option 3

Configure filestore on Tabadmincontroller node. For additional information about  filestore.exe, see Tableau Server File Store.

    Cause

    This behavior is related to Issue ID 891962, which has been fixed in a recent version of Tableau Server.

     
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