Error "The drivers necessary to connect to the database are not properly installed" Connecting to Netezza
Published: 03 Nov 2017 Last Modified Date: 07 Apr 2023
Issue
When trying to connect to a Netezza database, the following error may occur:
An error occurred while communicating with the IBM Netezza Database data source. The drivers necessary to connect to the database are not properly installed.
Environment
Tableau Desktop
Windows
Netezza
Resolution
Login and access IBM Passport Advantage to download the driver. The driver installer nzodbcsetup.exe is found in nz-winclient-version.zip.
Cause
Netezza's ODBC driver is not publicly available, and is therefore not bundled with Tableau Desktop.
Additional Information
For more information about IBM Netezza, see the Knowledge Center articles: