KNOWLEDGE BASE

Error "The driver required to connect to the data source isn't installed" after installing driver for Vertica on Tablea Server for Linux


Published: 20 Jul 2022
Last Modified Date: 21 Jul 2022

Issue

Error message "The driver required to connect to the data source isn't installed" when connecting to Vertica in web edit mode even though the driver is correctly installed.

Environment

  • Tableau Server 2022.1.2
  • Amazon Linux 2
  • Vertica

Resolution

Grant the read permission on odbcinst.ini file
chmod 644 /etc/odbcinst.ini

 

Cause

The /etc/odbcinst.ini does not have the read permission. For example:
$ ls -l /etc/odbcinst.ini
-rw-r----. 1 root root 221 Jul 19 10:51 /etc/odbcinst.ini

 
Did this article resolve the issue?