KNOWLEDGE BASE

Error “The database type Sqlserver is not supported” When Upgrading the Tableau Resource Monitoring Tool


Published: 20 Dec 2019
Last Modified Date: 20 Dec 2019

Issue

When performing an upgrade of the Tableau Resource Monitoring Tool that has previously been running an underlying SQL Server database, the following error message occurs:

"The database type Sqlserver is not supported" 

Environment

  • Tableau Server
  • Tableau Resource Monitoring Tool 2019.4.1 and later versions
  • Tableau Resource Monitoring Tool 2020.1 and later versions

Resolution

Completely uninstall your current version of the Tableau Resource Monitoring Tool and perform a fresh install of the latest version.

Cause

With Tableau 2019.4.1 and later or 2010.1 and later support has been removed for non-Postgres databases as repositories for RMT.
  • 2019.4 listed SQL Server as (deprecated) in our configuration menu.
  • 2019.4.1 and later will no longer support SQL Server at all due to performance improvements that require Postgres.
Did this article resolve the issue?