KNOWLEDGE BASE

Error "status code= 1000 Tableau detected that your OAuth refresh token is expired" When Refreshing Extract on Tableau Cloud


Published: 07 Jul 2023
Last Modified Date: 07 Jul 2023

Issue

When refreshing an extract, the following error may occur:

Unknown Failure ( status code = 1000, Unable to connect to data source with the supplied credentials, or no credentials provided. Tableau needs an unexpired OAuth refresh token to connect to the data. Authorize refresh tokens or ask the datasource owner for help. Tableau detected that your OAuth refresh token is expired. Reauthenticate with new credentials. Ask your Tableau admin if you need help. )

Environment

  • Tableau Cloud
  • OneDrive and SharePoint Online

Resolution

  1. Sign in to Tableau Cloud in a browser.
  2. At the top of the page, click your profile image or initials then select My Account Settings.  Scroll down to the Saved Credentials for Data Sources section.
  3. Look for saved credentials listed under OneDrive and SharePoint Online in the Saved Credentials for Data Sources section, click Delete next to the saved credentials. Then click Add and follow the prompts to connect to OneDrive and SharePoint Online and save the credentials.

Cause

The OAuth refresh token saved to the Tableau Cloud user account has expired.
Did this article resolve the issue?