기술 자료

macOS Catalina 10.15에서 설치할 때 ""Tableau Desktop.pkg" can't be opened because Apple cannot check it for malicious software" 오류 발생


게시 날짜: 21 Aug 2019
마지막 수정 날짜: 31 Oct 2019

문제

macOS Catalina 10.15에 Tableau 제품을 설치할 때 다음과 유사한 오류가 발생합니다.
"Tableau Desktop.pkg" can't be opened because Apple cannot check it for malicious software. This software needs to be updated. Contact the developer for more information."("Tableau Desktop.pkg"는 Apple이 악성 소프트웨어인지 여부를 확인할 수 없기 때문에 열 수 없습니다. 이 소프트웨어를 업데이트해야 합니다. 자세한 내용은 개발자에게 문의하십시오.")
사용자가 추가한 이미지

환경

  • macOS Catalina 10.15
  • Tableau Desktop 2019.2.1, 2019.1.5, 2018.3.8, 2018.2.11, 2018.1.14, 10.5.17, 10.4.18, 10.3.22, 10.2.22 이상 버전
  • Tableau Prep Builder 2019.2.2 이상 버전 
  • 2019년 6월 1일 이후에 릴리스된 Tableau Reader 및 Tableau Public 버전

해결 방법

옵션 1: 관리 권한이 있는 사용자로서, 소프트웨어에 실행 권한을 허용합니다.

  1.  원하는 Tableau 제품을 설치합니다.
  2. 확인을 클릭하여 오류를 해제합니다.
  3. 시스템 환경설정 > 보안 및 개인 정보 보호 > 일반 탭으로 이동합니다.
  4. 대화 상자 하단에 다음과 유사한 메시지가 표시됩니다.
     "Tableau Desktop.pkg" was blocked from use because it is not from an identified developer.("Tableau Desktop.pkg"는 확인된 개발자가 등록한 응용 프로그램이 아니기 때문에 사용할 수 없도록 차단했습니다.)
  5. 확인 없이 열기 단추를 클릭합니다. (확인 없이 열기 단추가 표시되지 않는 경우 2단계의 대화 상자에서 확인을 클릭해야 합니다.)
    사용자가 추가한 이미지
  6. 설치 프로그램이 다시 시작되고 이전과 동일한 경고 메시지가 표시됩니다.
    이제 열기 단추와 취소 단추가 있습니다.
  7. 열기를 클릭하고 설치를 계속합니다.
사용자가 추가한 이미지

옵션 2. 2019년 6월 이전 버전 설치

해결 방법으로, 2019년 6월 1일 이전에 배포된 Tableau 소프트웨어 버전은 여전히 macOS Catalina에서 설치할 수 있습니다. 여기에는 다음과 같은 유지 관리 버전이 포함됩니다.

Tableau Desktop: 2019.2.0, 2019.1.4, 2018.3.7, 2018.2.10, 2018.1.13. 10.5.16, 10.4.17, 10.3.21
Tableau Prep: 2019.2.1 이하 버전
Tableau Reader: Tableau Reader 2019.2.0 
Tableau Desktop Public: Tableau Public Desktop 2019.2.0 

이러한 버전 중 하나를 설치한 다음 도움말 > 제품 업데이트 확인을 사용하여 해당 버전에 사용할 수 있는 최신 유지 관리 버전을 설치합니다. Tableau 제품의 이전 유지 관리 버전에 대한 자세한 정보와 액세스하는 방법은 제품 다운로드 및 릴리스 정보를 참조하십시오.

원인

이 동작은 현재 원인을 조사 중인 알려진 문제(ID 946418)와 관련이 있습니다.
Apple은 macOS Catalina 10.15에 소프트웨어를 설치하기 위한 보안 요구 사항을 높였습니다. 

 
이 문서로 문제가 해결되었습니까?