ナレッジベース

macOS Catalina 10.15 でのインストール時のエラー ""Tableau Desktop.pkg" can't be opened because Apple cannot check it for malicious software"


発行: 21 Aug 2019
最終修正日: 31 Oct 2019

問題

Tableau 製品を macOS Catalina 10.15 でインストールすると、次のようなエラーが発生します。
"Tableau Desktop.pkg" can't be opened because Apple cannot check it for malicious software. This software needs to be updated. Contact the developer for more information. ("Tableau Desktop.pkg" が悪質なソフトウェアかどうかを Apple では確認できないため、このソフトウェアは開けません。このソフトウェアはアップデートが必要です。詳しくは開発元にお問い合わせください。)"
ユーザーが追加した画像

環境

  • macOS Catalina 10.15
  • Tableau Desktop 2019.2.1、2019.1.5、2018.3.8、2018.2.11、2018.1.14、10.5.17、10.4.18、10.3.22、10.2.22 以降のバージョン
  • Tableau Prep Builder 2019.2.2 以降のバージョン
  • 2019 年 6 月 1 日以降にリリースされた Tableau Reader および Tableau Public バージョン

解決策

オプション 1: 管理者権限を持つユーザーとして、ソフトウェアに実行のパーミッションを付与する。

  1. 目的の Tableau 製品のインストールを試みます。
  2. [OK] をクリックしてエラーを閉じます。
  3. [システム環境設定] > [セキュリティとプライバシー] > [一般] タブに移動します。
  4. ダイアログの下部に、次のようなメッセージが表示されます。
     "Tableau Desktop.pkg" は開発元を確認できないため、開けませんでした。
  5. [このまま開く] ボタンをクリックします。([このまま開く] ボタンが表示されない場合、ステップ 2 のダイアログで必ず [OK] をクリックするようにしてください。)
    ユーザーが追加した画像
  6. インストーラーが再び起動し、以前と同じ警告メッセージが表示されます。
    今回は [開く] ボタンと [キャンセル] ボタンがあります。
  7. [開く] をクリックすると、インストールが続行されます。
ユーザーが追加した画像

オプション 2: 2019 年 6 月より前のバージョンをインストールする

回避策として、2019 年 6 月 1 日より前に出荷された Tableau ソフトウェアのバージョンを、引き続き macOS Catalina でインストールできます。これには、次のメンテナンス リリースが含まれます。

Tableau Desktop: 2019.2.0、2019.1.4、2018.3.7、2018.2.10、2018.1.13、10.5.16、10.4.17、10.3.21
Tableau Prep: 2019.2.1 以前のバージョン
Tableau Reader: Tableau Reader 2019.2.0 
Tableau Desktop Public: Tableau Public Desktop 2019.2.0 

これらのバージョンのいずれかをインストールし、[ヘルプ] > [製品の更新をチェック] を使用して、そのバージョンで利用可能な最新のメンテナンス リリースをインストールします。詳細および Tableau 製品の以前のメンテナンス リリースへのアクセスについては、「製品のダウンロードおよびリリース ノート」を参照してください。

原因

この動作は現在調査中の既知の問題 (ID 946418) と関連しています。
Apple は、macOS Catalina 10.15 上でインストールするソフトウェアのセキュリティ要件を強化しました。

 

詳細情報

Tableau Prep Builder を Mac で起動中に発生するエラー: "The My Tableau Prep repository is either read only or can't be found"
macOS Catalina 10.15 でのエラー "custactutil can't be opened because its integrity cannot be verified"


Tableau 製品の新しいバージョンは、Mac が Catalina にアップグレードされる前にインストールされている場合、macOS Catalina で動作します。

Apple Developer News



この記事についてディスカッションする... フィードバック フォーラム
この記事で問題は解決しましたか?