BASE DE CONNAISSANCES

Erreur : ""Tableau Desktop.pkg" can't be opened because Apple cannot check it for malicious software" lors de l'installation sur macOS Catalina 10.15


Date de publication : 21 Aug 2019
Date de dernière modification : 30 Jul 2020

Problème

Lors de l'installation d'un produit Tableau sur macOS Catalina 10.15, une erreur du type suivant se produit :
"Tableau Desktop.pkg" can't be opened because Apple cannot check it for malicious software. This software needs to be updated. Contact the developer for more information. (Impossible d'ouvrir Tableau Desktop.pkg parce qu'Apple ne peut pas rechercher les logiciels malveillants. Ce logiciel a besoin d'être mis à jour. Contactez le développeur pour plus d'informations)
Image ajoutée par l'utilisateur

Environnement

  • macOS Catalina 10.15
  • Tableau Desktop 2019.2.1, 2019.1.5, 2018.3.8, 2018.2.11, 2018.1.14, 10.5.17, 10.4.18, 10.3.22, 10.2.22 et versions plus récentes
  • Tableau Prep Builder 2019.2.2 et 2019.2.3
  • Versions de Tableau Reader et Tableau Public distribuées après le 1er juin 2019

Résolution

Option 1 : Mettre à niveau à Tableau Desktop 2019.3, Tableau Prep 2019.3.1 ou versions ultérieures.

Le problème a été corrigé dans Tableau Desktop 2019.3 et Tableau Prep Builder 2019.3.1 et versions ultérieures.


Option 2 : En tant qu'utilisateur doté de droits d'administration, vous pouvez donner au logiciel l'autorisation de s'exécuter.

  1. Tentative d'installation du produit Tableau souhaité.
  2. Cliquez sur OK pour ignorer l'erreur.
  3. Accédez à l'onglet Préférences système > Sécurité et confidentialité > Général.
  4. Dans la partie inférieure de la boîte de dialogue, vous verrez un message du type suivant :
    « Tableau Desktop.pkg » a été bloqué parce qu'il ne provient pas d'un développeur identifié.
  5. Cliquez sur le bouton Ouvrir quand même. (Si le bouton Ouvrir quand même ne s'affiche pas, veillez à cliquer sur OK dans la boîte de dialogue à l'étape 2.)
    Image ajoutée par l'utilisateur
  6. Le programme d'installation va démarrer et afficher le même message d'avertissement qu'auparavant.
    Vous verrez désormais un bouton Ouvrir et un bouton Annuler.
  7. Cliquez sur Ouvrir et l'installation se poursuivra.
Image ajoutée par l'utilisateur

Option 3 : Installer une version antérieure à mai 2019

Il existe une solution : les versions du logiciel Tableau livrées avant le 1er mai 2019 peuvent encore être installées sur macOS Catalina. Cela inclut les versions de maintenance suivantes :

Tableau Desktop : 2019.2.0, 2019.1.3, 2018.3.6, 2018.2.9, 2018.1.12. 10.5.15, 10.4.16, 10.3.20
Tableau Prep : 2019.1 et versions antérieures

REMARQUE : Tableau Desktop 2019.2.0 a été distribuée en mai, mais cette version n'est pas affectée et peut être installée sur macOS 10.15 Catalina sans problème.

Installez l'une de ces versions, puis utilisez Aide > Rechercher les mises à jour du produit pour installer la version de maintenance la plus récente disponible pour cette version. Pour plus d'informations et pour accéder à des versions de maintenance plus anciennes de produits Tableau, consultez Téléchargements de produits et notes de version.

Cause

Ce comportement est lié à un problème connu ID 946418 qui est actuellement en cours d'examen.
Apple a renforcé les exigences de sécurité pour les logiciels à installer sur macOS Catalina 10.15. 

 

Informations supplémentaires

 Erreur : « The My Tableau Prep repository is either read only or can't be found » lors du lancement de Tableau Prep Builder sur Mac
Erreur : « custactutil can't be opened because its integrity cannot be verified » sur macOS Catalina 10.15


Des versions plus récentes de produits Tableau fonctionneront sur macOS Catalina à condition qu'elles aient été installées avant la mise à nivea du Mac à Catalina. 

Apple Developer News



Discuter de cet article... Forum de commentaires
Cet article vous a-t-il permis de résoudre le problème ?