Error: "Tableau Data Engine Error: 4: ... Path Does Not Exist" Refreshing Extract on Tableau Online
Published: 10 Oct 2014 Last Modified Date: 22 Jan 2019
Issue
When you try to refresh an extract published to Tableau Online by using the Tableau Data Extract Command-Line Utility, the following error might occur:
Tableau Data Engine Error: 4: Invalid Command: Database: Path Does Not Exist
Environment
Tableau Online
Extracts
Resolution
One of the following troubleshooting steps might resolve this issue:
Remove the @<data source provider>.com part of the username from the --source-username option in the command.
For example: --source-username <username>@<data source provider>.com
Would become: --source-username <username>
Verify that all the fields necessary to connect to the data source are included in the command-line script, including --source-username and --source-password.
Verify that the computer running the command has permission to access the file path specified for --original-file.
Verify that the --original-file path is using the server name and not the drive name. For example, the command should begin with\\<servername>\ rather than D:\.
Cause
The Tableau Extract Refresh Utility is unable to connect to the data source.