KNOWLEDGE BASE

Error "[SQLState XX000] extraneous data in \"T\" message" When Refreshing Redshift Extract in Tableau Online


Published: 07 Jan 2022
Last Modified Date: 19 Jan 2022

Issue

After the driver upgrade to Tableau Online for Amazon Redshift, connections and extract refreshes are failing with the error:
 
[Amazon][Amazon Redshift] (30) Error occurred while trying to execute a query: [SQLState XX000] extraneous
data in \"T\" message\nUnable to connect to the Amazon Redshift server \"[Server]\". Check that the server is running and that you have access privileges to the requested database.

In addition, you can connect to Amazon Redshift in Web Edit mode, but cannot see any table fields populated successfully or work with the data.

Environment

  • Tableau Online
  • Amazon Redshift

Resolution

If you are affected by this issue, please submit a case to the Amazon Redshift partner engineering team at redshift-partners@amazon.com

Note: If you are using Greenhouse as your Redshift hosting platform, please mention this within your ticket submitted to Amazon, as well as the known issue ID below for Amazon's reference. Amazon is investigating potential workarounds from their side as well while they work on developing a fix for the issue.

As a few possible workarounds to the issue, the following options are available:

Option 1: 
  • Refresh the data using Tableau Bridge, and switching the connection type to the Private Network option to refresh through Bridge instead of Online.
Option 2:
  • Download a local copy of the data source in Tableau Online, refresh it locally in Tableau Desktop, and republish the data source to Tableau Online manually.

Cause

This issue is caused by the recent driver upgrade to Tableau Online on 12/16. 

Additional Information

The Tableau Development team is actively working directly with Amazon to investigate and resolve this issue under Known Issue ID 1357543.
 
Did this article resolve the issue?