KNOWLEDGE BASE

Error "[SQLState XX000] extraneous data in \"T\" message" When Refreshing Redshift Extract in Tableau Cloud


Published: 07 Jan 2022
Last Modified Date: 08 Jun 2022

Issue

After the driver upgrade to Tableau Cloud for Amazon Redshift, connections and extract refreshes are failing with the error:
 
[Amazon][Amazon Redshift] (30) Error occurred while trying to execute a query: [SQLState XX000] extraneous
data in \"T\" message\nUnable to connect to the Amazon Redshift server \"[Server]\". Check that the server is running and that you have access privileges to the requested database.

In addition, you can connect to Amazon Redshift in Web Edit mode, but cannot see any table fields populated successfully or work with the data.

Environment

  • Tableau Cloud
  • Amazon Redshift

Resolution

As a few possible workarounds to the issue, the following options are available:

Option 1: 
  • Refresh the data using Tableau Bridge, and switching the connection type to the Private Network option to refresh through Bridge instead of Online.
Note: If using Greenhouse, contact Greenhouse to confirm whether they can allow connections from the Bridge machine to connect to the database to refresh the data. 

Option 2:
  • Download a local copy of the data source in Tableau Cloud, refresh it locally in Tableau Desktop, and republish the data source to Tableau Cloud manually.

Cause

This issue is caused by the recent driver upgrade to Tableau Cloud on 12/16.

Additional Information

The Tableau Development team is actively working on testing a driver fix to resolve this issue under Known Issue ID 1357543. 
Did this article resolve the issue?