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Error "[Simba][AthenaJDBC](100131) An error has been thrown from the AWS SDK client. Unable to execute HTTP request:Connection Reset" Connecting to Amazon Athena Data Source


Published: 29 Oct 2018
Last Modified Date: 28 Jan 2020

Issue

After connecting to Amazon Athena from Tableau Desktop, the data does not appear in the connection window and the following errors might occur when dragging a field into the view or viewing the data: 
 
[Simba][AthenaJDBC](100131) An error has been thrown from the AWS SDK client. Unable to execute HTTP request:Connection Reset

OR

[Simba][AthenaJDBC](100123) An error has occurred. Exception during column initialization: Details: Unable to execute HTTP request:Connect to [Athena us-east-1-amazonaws.com……..] failed: Connection timed out: connect[Execution ID:xxxxxxxx-xxxx...........]

Environment

  • Tableau Desktop
  • Amazon Athena

Resolution

Work with your IT team to ensure that communication on Port 444 is not blocked. 

Cause

Port 444 is blocked. Access to port 444 is required as this port is used by the Athena service to stream query results

Additional Information

Athena JDBC drivers newer than 2.0.2 use QueryResultStreaming (athena:GetQueryResultsStream) to retrieve the query results. QueryResultStreaming uses a different port on outbound (444) than usual (443) and both ports must be to be opened. This behavior is documented on Athena's driver release page.


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