KNOWLEDGE BASE

Error "Session interrupted. Your workbook has been restored to a previous state" After a View Reloads and all Filters are Lost


Published: 20 Sep 2019
Last Modified Date: 12 Feb 2020

Issue

When a view reloads and all applied filters are lost, the following yellow error message unexpectedly occurs at irregular times or during active sessions:

"Session Interrupted. Your workbook has been restored to a previous state"
 

Additionally, you may find HTTP 410 errors in the gateway access.log due to unrelated sessions ending.

Environment

Tableau Server 2019.3, 2019.2 - 2019.2.3, 2019.1.3 - 2019.1.7, 2018.3.6 - 2018.3.11, 2018.2.9 - 2018.2.14

Cause

This behavior is related to a known issue with ID # 937785, which has been resolved in the latest releases of Tableau Server.

 

Additional Information

Important: This same error message is expected to occur when a view has been open for a long period of time (Default is 30 minutes). With this issue, users or server administrators may report seemingly random "session interrupted your workbook has been restored" messages when working with views. For additional information about this behavior, see the following Knowledge Base article: Error "Session Interrupted. Your workbook has been restored to a previous state" After a View Times out.

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