ナレッジベース

Tableau Server のインストール中のエラー "Service 'tablicsrv' failed to start" "No license found for Tableau Server" または "Tableau Server is unlicensed"


発行: 31 Mar 2016
最終修正日: 20 Jul 2023

問題

Tableau Server をインストールしても、TSM でライセンス認証されたキーが反映されず、ライセンスの認証時または tablicsrv の開始時に、次のエラーのいずれかが発生する場合があります。

No license found for Tableau Server or No specified license found. (Tableau Server に対するライセンス、または指定したライセンスが見つかりませんでした。)
または
Tableau Server is unlicensed. An administrator must run manage product keys. (Tableau Server のライセンスがありません。管理者は、プロダクト キーの管理を行う必要があります。)
または
"Service 'tablicsrv' failed to start (state 1)" ("サービス 'tablicsrv' の起動に失敗しました (状態 1)")
または
Unable to start service 'tablicsrv': (5) Access is denied (サービス 'tablicsrv' を起動できません: (5) アクセスが拒否されました)
または
service on Local Computer started and then stopped. Some services stop automatically if they are not in use by other services or programs. (ローカル コンピューター上のサービスが開始してから停止しました。他のサービスやプログラムによって使用されていない場合、一部のサービスは自動的に停止します。)

環境

Tableau Server

解決策

パーミッションの検証と更新

グループ ポリシーやその他のシステム管理ソリューションを使用して、アプリケーション サーバーのパーミッションおよびアカウントを標準化している組織もあります。組織でこのようなソリューションを実行している場合は、実行サービス アカウントで必要となるフォルダー パーミッションに対応するようシステムを設定する必要があります。実行サービス アカウントのフォルダー パーミッションを変更した場合は、TSM を使用してパーミッションを再適用できます。「既存のドメイン実行サービス アカウントを別のアカウントに変更している」を参照してください

Tableau Server インストール ディレクトリ (%PROGRAMDATA%\Tableau\Tableau Server) に移動し、[プロパティ] > [セキュリティ] を開いて、組織がインストール ディレクトリからユーザー グループ情報を削除しているかどうかを確認できます。ユーザー グループがリストされていない場合、パーミッションを更新する必要があります。

多くの組織は変更管理ソリューションを使用して起動中にユーザー グループを削除しているため、単純に Tableau Server インストール ディレクトリにユーザー グループを再び追加することはベスト プラクティスではありません。

代わりに、Windows の icacls  コマンドを使用して、Tableau Server インストール ディレクトリのパーミッションをローカル サービスに適用します。

パーミッションを適用するには:

  1. Tableau Server が実行されているコンピューターに管理者としてログオンします。

  2. コマンド プロンプトを開き、次のコマンドを実行します。

    icacls “%PROGRAMDATA%\Tableau\Tableau Server” /reset

    このコマンドはパーミッションをリセットし、インストール ディレクトリでの継承を有効にします。

    icacls “%PROGRAMDATA%\Tableau\Tableau Server” /grant *S-1-5-19:(OI)(CI)F /T

    このコマンドは、ローカル サービス アカウント (ここではグローバル セキュリティ識別子「*S-1-5-19」で表されます) にパーミッションを明示的に付与します。

  3. Tableau Server ライセンス マネージャーを再起動します (一部の環境では、パーミッションを有効にするために、コンピューター全体を再起動する必要があります)。

Windows のフォルダーのプロパティを使用してパーミッションを設定する場合は、次の手順に従います。
  1. Tableau Server の bin ディレクトリとログ ディレクトリの両方のパーミッションを確認します。
    Tableau Server を既定の Windows プログラムとデータ パスを使用してインストールした場合は、次のフォルダーを確認してください。
    • C:\ProgramData\Tableau\Tableau Server\logs
    • C:\Program Files\Tableau\Tableau Server\bin

      Tableau Server をカスタム パスにインストールした場合、ログと bin フォルダーはいずれもインストール ディレクトリのベースにあります。フォルダー パーミッションの詳細については、オンライン ヘルプを参照してください。
  2. 内蔵のユーザー グループやローカル アカウントが、"読み取りと実行"、"フォルダーの内容の一覧表示"、"読み取り" パーミッションを持って存在していることを確認します。
  3. [詳細] をクリックして、特殊なアクセス許可を確認します。[ファイルの作成/データの書き込み] が選択されていることを確認します。[高度なアクセス許可] ウィンドウのスクリーンショット

原因

バックグラウンド

Tableau Server 9.3 以降、Tableau Server ライセンス マネージャー (tablicsrv) 構成に変更が加えられました。 以前のバージョンでは、tablicsrv.exe は、NT AUTHORITY\Local System のセキュリティ コンテキスト (ログオン値) の下で実行していました。これは、新しい Windows サービスを作成するときの既定の実行ユーザー アカウントです。 ローカル システムは、ライセンス マネージャーを正常に実行するために必要なもの以上のアクセスを持っています。そのため、実行ユーザーはより制限された NT AUTHORITY\Local account に変更されました。 ローカル サービス アカウントは、ライセンス マネージャーが Tableau Server インストール ディレクトリ (%PROGRAMDATA%\Tableau\Tableau Server) に格納されているファイルへのアクセスやファイルの実行を行ったり、tablicsrv.log ファイルに書き込んだりするために使用します。 これらのアクションは、Tableau Server インストール ディレクトリのユーザー セキュリティ グループを通じて継承されたパーミッションを信頼します。

[Tableau Server のプロパティ] ウィンドウで、[読み取りと実行]、[フォルダーの内容の一覧表示]、[読み取り]、[特殊なアクセス許可] チェックマークがオンになっている画像

上記のように、次のパーミッション (ローカル サービスによって継承されたものすべて) がユーザー セキュリティ グループに付与されます。

  • 読み取りと実行
  • フォルダーの内容の一覧表示
  • 読み取り
  • 特殊なアクセス許可 (ファイルの作成/データの書き込み)

ローカル サービスがこれらのパーミッションを持っていない場合、Tableau Server はインストール中に初期化に失敗し、上記のエラーが表示されます。

ローカル サービスに正しいパーミッションがないのはなぜですか?

セキュリティ対策として、一部の組織では、環境内のすべてのインストール ディレクトリからユーザー グループを削除します。通常、このような組織は、グループ ポリシーなどの自動変更管理ソフトウェア ソリューションを使用してユーザー グループを削除します。

詳細情報

管理サービスおよびライセンス サービスが実行中であることを確認します。

ライセンス マネージャーは、ローカル サービスに適用されている既定の Windows フォルダー パーミッションに依存します。Tableau インストール ディレクトリのパーミッションは、より安全な環境で変更する必要があります。安全な環境でないと、ライセンス発行エラーが発生する可能性があります。詳細については、「Tableau Service 設定の確認」オンライン ヘルプを参照してください。

Windows でのフォルダー パーミッションの設定に関する詳細については、Microsoft TechNet および Tableau 製品ヘルプで次の記事を参照してください。

この記事で問題は解決しましたか?