KNOWLEDGE BASE

Error "Running step CheckBackupCompatibility failed" After Failing to Restore Tableau Server


Published: 27 May 2019
Last Modified Date: 28 May 2019

Issue

When restoring a backup to a new environment, the following error might occur:

ERROR com.tableausoftware.tabadmin.webapp.asyncjobs.JobStepRunner - Running step CheckBackupCompatibility failed


Additionally, after looking at logs, you may notice that some values are not enclosed in quotation marks. For example: 

 in "<reader>", line 35, column 39:

   *

   ^

Environment

  • Tableau Server 2018.3.6
  • Windows Server 2012

Resolution

Work with your Tableau Server Administrator (or IT team) to perform the steps below: 

Step 1 

Find and unzip the .tsbak file. In this file, find the line and column that contain the * sign that is not encased in quotation marks.
Such file is located at C:\Program Files\Tableau\Tableau Server\[version]\bin in Tableau Server pre-tsm.

Step 2

Compare the line/column with the logs of the config.yml to find the expected alphabetic or numeric character.
For example, the value vizportal.rest_api.cors.allow_origin: * in the .tsbak file should show as vizportal.rest_api.cors.allow_origin: "*" in the config.yml file.

Step 3

Use the ‘tabadmin set’ command to set the correct value. In this example, we will reset the value of 'vizportal.rest_api.cors.allow_origin': 
tabadmin stop
tabadmin set vizportal.rest_api.cors.allow_origin "*"
tabadmin config
tabadmin start

Step 4

Re-generate Tableau Server backup file and verify the integrity of Postgres database by using the command  tabadmin backup tabserver -v
Then, perform a restore of Tableau Server

Cause

The value of 'vizportal.rest_api.cors.allow_origin' should be enclosed by double quotes.
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