KNOWLEDGE BASE

Error "Retrieved async job status Failed" Restoring Backup


Published: 04 Apr 2018
Last Modified Date: 04 Mar 2020

Issue

Restoring from a .tsbak file on Linux fails during the compatibility check.

tsm.log shows something like:
 
2018-04-03 23:06:53 main : INFO  com.tableausoftware.tabadmin.async.AsyncJobDelegate - Retrieved async job status Failed. Id=10, progress=100
2018-04-03 23:06:53 main : ERROR com.tableausoftware.tabadmin.async.AsyncJobDelegate - Asynchronous job 10 completed but wasn't successful.
2018-04-03 23:06:53 main : ERROR com.tableausoftware.tabadmin.Tabadmin - Restoring the backup 'tableaubackup.tsbak' was unsuccessful.

tabadmincontroller logs show:
 
2018-04-03 23:06:52.676 +0000 pool-11-thread-1 : ERROR com.tableausoftware.tabadmin.webapp.asyncjobs.JobStepRunner - Running step CheckBackupCompatibility failed
com.tableausoftware.tabadmin.webapp.restore.BackupCompatibilityResult$CheckFailedException: Check failed
    at com.tableausoftware.tabadmin.webapp.restore.BackupCompatibilityResult.failed(BackupCompatibilityResult.java:47)
    at com.tableausoftware.tabadmin.webapp.restore.BackupCompatibilityChecker.checkBackupReadable(BackupCompatibilityChecker.java:117)
...
2018-04-03 23:06:52.676 +0000 pool-11-thread-1 : DEBUG com.tableausoftware.tabadmin.webapp.asyncjobs.JobStepRunner - Progress update for job 10, step: CheckBackupCompatibility, status: Failed, message key: job.restore.step.check_backup_compatibility.no_read_access, message data: 

Environment

  • Tableau Server 
  • Linux OS

Resolution

Change the owner of the backup file to tsmagent. For example, from the directory containing the backup:

sudo chown tsmagent YourBackup.tsbak

For more information about this system user, see System User, Sudo Privileges, and Systemd.

 

Cause

Lack of read permissions on the .tsbak file. 


 
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