KNOWLEDGE BASE

Error "Reconnect to..." when working with published datasource in Tableau Desktop


Published: 19 May 2021
Last Modified Date: 19 May 2021

Issue

When using published datasource to work with Tableau Desktop, user has frequently observed the datasource disconnect issue which forces them to manually reconnect the published datasource.

"Reconnect to [datasource name]"

Environment

  • Tableau Server 
  • Tableau Desktop

Resolution

  Increase the timeout value with the following commands:
  •    tsm stop
  •    tsm configuration set -k wgserver.session.idle_limit -v 120
  •    tsm pending-changes apply
  •    tsm start
For wgserver.session.idle_limit, the default value is 240 minutes. It depends on how much user works on Tableau Desktop.

Cause

The behavior was caused by wgserver session idle timeout setting that was set too short (e.g. 30 mins). 
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