KNOWLEDGE BASE

Error "Part of the installer exited with error code (10)" Installing or Upgrading Tableau Server


Published: 18 Jan 2019
Last Modified Date: 09 Aug 2021

Issue

When you try to install or upgrade Tableau Server, the following error occurs: 
Setup 
WARNING: The server may not have started properly. Part of the installer exited with error code: (10). Check the logs: 
C:\Program Files\Tableau\Tableau server\logs\app-install.log for more information

 
This error is seen repeated many times in the app-installer log:
 
2019-01-17 10:46:10.163 -0500 ZKWorker-ScheduledTask-0-SendThread(VHADURAPPTABLE1.v06.med.va.gov:8749) : WARN  org.apache.zookeeper.ClientCnxn - Session 0x0 for server null, unexpected error, closing socket connection and attempting reconnect
java.net.ConnectException: Connection refused: no further information
at sun.nio.ch.SocketChannelImpl.checkConnect(Native Method)
at sun.nio.ch.SocketChannelImpl.finishConnect(SocketChannelImpl.java:717)
at org.apache.zookeeper.ClientCnxnSocketNIO.doTransport(ClientCnxnSocketNIO.java:361)
at org.apache.zookeeper.ClientCnxn$SendThread.run(ClientCnxn.java:1144)

Environment

  • Tableau Server 2018.3.0 - Tableau Server 2018.3.2
  • Windows Server 2012
  • McAfee Firewall or Antivirus 

Resolution

  • Ensure that McAfee Firewall is set to Adaptive Mode or disabled completely
  • Ensure that antivirus exceptions have been configured

Cause

McAfee Firewall was enabled.
Did this article resolve the issue?