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Error "Page can't be found" When Enabling SAML, Tableau Server Starts in DEGRADED State


Published: 12 Sep 2018
Last Modified Date: 15 Sep 2018

Issue

When enabling SAML on Tableau Server, a Tableau Server node starts in DEGRADED state, and upon trying to open Tableau Server in a browser, there is an error:

"This page can't be found.
No webpage was found for this address: <server url>/vizporal/api/saml?dest=%2F&sendPodInfo=false&authSetting=&siteLuid=&embedded=false"

"tabadmin status -v" (Windows) or "tsm status -v" (Linux) shows that Application Server is unavailable or in error state.

Environment

  • Tableau Server 2018.1
  • SAML

Resolution

Follow these steps to retrieve the SAML key file:

Windows
  1. Run the following command as Admin:
    • tabadmin get wgserver.saml.key.file
  2. Verify that there is a key with the above path
  3. Verify the file name exactly as is on the Tableau Server nodes, where the Application Server (vizportal) process is showing status errors..
  4. Ensure that the file is readable by the Tableau Server Run As User service account.
Linux
  1. Run the following command as Admin:
    • tsm configuration get -k wgserver.saml.key.file
  2. Verify that there is a key with the above path
  3. Verify the file name exactly as is on the Tableau Server nodes, where the Application Server (vizportal) process is showing status errors.

Cause

Tableau Server is unable to find the key file used to configure SAML.

Additional Information

Vizportal logs on the affected nodes will show the following error:

java.io.FileNotFoundException: The key file <path/keyfile.key> may not exist or there is no permission to read the file [Access is denied]. Please check the folder permissions.


Note that this problem should not affect versions 2018.2 and later, as the Client File Service will handle managing the SAML key file.

See Configure Client File Service for Windows or Configure Client File Service for Linux for details.
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