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Errors "Operation Cancelled." Or "The query time resource limit (7200 seconds) was exceeded" When Refreshing Tableau Cloud Extract


Published: 13 Mar 2015
Last Modified Date: 20 Jul 2023

Issue

When refreshing an extract published to Tableau Cloud, one of the following errors might occur: 
 
The query time resource limit (7200 seconds) was exceeded
 
Or:

com.tableausoftware.nativeapi.dll.TableauCancelException: Operation cancelled.
 
Or: 

The query time resource limit (8100 seconds) was exceeded.​

Environment

  • Tableau Cloud
  • Tableau Data Extract

Resolution

To resolve this error, use one of the following options:

Option 1

Use live connections instead of extracts. See Keep Data Fresh for identifying which cloud-based data sources are capable of connecting live on Tableau Cloud. 

Option 2

Use incremental extracts. See Refresh Extracts for more information. 

Option 3

Decrease the size of the data extract. Two common ways to do this: 

Option 4

Refresh the published extract using Tableau Bridge, the Command Line Utility, or manually using Tableau Desktop. For more information, see the Related Links. 

Option 5

Try scheduling extract refreshes at different times of day, or at night.

 

Cause

Tableau Cloud has a session timeout limit of 2 hours (120 minutes, 7200 seconds), which cannot be modified.

Additional Information

On the Background Tasks error tooltip, the Started At and Completed At times should be exactly 2 hours apart.

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