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Error "Missing password. Invalid username or password." Connecting to Athena After 2023.2 Release in Tableau Cloud


Published: 15 Jun 2023
Last Modified Date: 16 Jun 2023

Issue

When trying to refresh an Athena extract, connect live, or republish an affected data source, the following errors occur: 

Missing password. Invalid username or password.

Or

Tableau can't publish a live connection to Athena..

Environment

  • Tableau Cloud 2023.2
  • Amazon Athena

Resolution

Edit, Re-Publish and Embed Credentials Using Tableau Cloud

Live Connections

  1. Login to Tableau Cloud in a web browser. 
  2. Navigate to an impacted Athena data source or workbook. 
  3. Select Edit Workbook, or Edit Data Source
  4. Re-enter your credentials when prompted, select the data source and Edit Connection.
  5. Enter your password and select Sign In.
  6. Select Publish, and ensure the Embed credentials box is selected.
  7. Select Publish.

Extracted Connections

  1. Login to Tableau Cloud in a web browser. 
  2. Navigate to an impacted Athena data source or workbook. 
  3. Select Edit Workbook, or Edit Data Source
  4. Select the data source and select Edit Data Source, then Edit Connection.
  5. Enter your password and select Sign In.
  6. Select Publish, and ensure the Embed credentials box is selected.
  7. Select Publish.

Cause

This error is under investigation by the Tableau Development Team and can be viewed on the Salesforce Known Issue website under W-13514238.
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