KNOWLEDGE BASE

Error ​​​​​​​"Internet communication error: Couldn't connect to server" or Background Maps not Loading


Published: 14 Aug 2019
Last Modified Date: 15 Aug 2019

Issue

When attempting to load a view, the visualization is unresponsive and no background maps (Mapbox) are visible on the view. Additionally, the following error is displayed: 

"Internet communication error: Couldn't connect to server "

Environment

  • Tableau Server 2019.2.0 - 2019.2.2
  • Tableau Desktop 2019.2.0 - 2019.2.2
  • Mapbox

Resolution

Upgrade to Tableau Server 2019.2.3 (or later versions) or Tableau Desktop 2019.2.3 (or later versions).

Cause

This behavior was fixed in a recent version of Tableau. Note: restrictions on port 80 can aslo result in such behavior. 
Did this article resolve the issue?