KNOWLEDGE BASE

Error "HTTP 400: There was an error with the data source "<data source name>". Verify that the data source is configured correctly." When Loading a view


Published: 05 Dec 2019
Last Modified Date: 20 Dec 2019

Issue

After upgrading Tableau Server and/or attempting to load a view on Tableau Server the following error might occur:When some users try to access a view on Tableau Server, they receive an error saying: 

HTTP 400: There was an error with the data source "<data source name>". Verify that the data source is configured correctly.


Additionally, when loading a view in Tableau Server, an extra error message might appear indicating that the session was ended by server. and will contain an HTTP 400 error along with the following error: 

"Unable to connect to the server 'localhost'".

 

Environment

Tableau Server 2019.2.0 and higher versions

Resolution

Option 1

Upgrade to Tableau Server 2019.4.1 or a newer version. Click here for downloads of current and previous versions of Tableau Server: Tableau Server Downloads and Release Notes. For more information on current releases, see Upgrade Tableau Server and Server Upgrade.

Option 2

This issue can arise when the user attempting to load the view is a member of many Tableau Server groups. As a test and workaround, please ensure that the user experiencing this issue is a member of multiple groups, and then remove them from as many as possible. If they are able to access the view after having been removed from many groups, this is likely the issue being encountered.


 

Cause

This issue (ID 1023705) has been fixed in a recent release of Tableau Server.
Did this article resolve the issue?