知识库

在 Mac 上激活或安装时出现错误“尝试修复受信任的存储时出现意外错误”


发布时间: 13 Jan 2016
上次修改日期: 09 May 2022

问题

当您尝试激活 Tableau Desktop 时,可能会发生以下错误:

尝试修复 Trusted Storage 时发生意外错误。

或 

函数 flxActCommonRepairLocalTrustedStorage 返回了错误 (50044, 71013, 19810)
LM_TS_LOCAL_REPAIR
尝试修复 Trusted Storage 时发生意外错误。


或 

函数 flxActCommonRepairLocalTrustedStorage 返回了错误 (50044, 71013, 27)
LM_TS_LOCAL_REPAIR
尝试修复 Trusted Storage 时发生意外错误。




尝试使用 custactutil 审查受信任的存储时发生错误:
flxActCommonLicSpcPopulateAllFromTS (50030, 71521,17005)
 

环境

  • Tableau Desktop
  • Mac OS
  • 第三方软件

解决方案

选项 1 - 适用于 Tableau Desktop 2019.3 及更高版本

请重新运行安装程序,因为 Flexnet 软件包不再能够拆分。 


选项 2 - 适用于 Tableau Desktop 所有版本

请注意,使用下面的方法可能会对也使用 FLEXnet 运行的其他应用程序产生影响。请在继续之前咨询您的 IT 团队。

在运行 Tableau Desktop 的计算机上,请从 Library 文件夹中手动移除 FLEXnet 首选项文件。若要查找并移除 FlexNet 首选项文件,请参见下面的步骤:
  1. 关闭 Tableau Desktop
  2. 打开“访达”
  3. 从屏幕顶部的菜单栏中选择“执行”>“转到文件夹”
  4. 输入 /Library/Preferences/FLEXnet Publisher/FLEXnet,并选择“执行”
  5. 突出显示目录中的所有项目,并使用按键 CMD + DELETE 将其删除
    • 注意:如果在突出显示项目时选择了齿轮图标 >“移到废纸篓”选项,则文件也可能被删除
  6. 重新启动计算机
  7. 打开 Tableau Desktop 并输入您的产品密钥以激活产品(如有必要)。 

选项 3 - 适用于 Tableau Desktop 2019.2 及更低版本

在运行 Tableau Desktop 的计算机上,请手动重新安装 FlexNet 软件包。若要查找并安装 FlexNet 许可组件,请参见下面的步骤:
  1. 在 Finder 中,单击“应用程序”
  2. 按住 Control 键,单击“Tableau”,然后选择“显示软件包内容”
  3. 双击“内容”,双击“安装程序”,然后双击“Tableau FLEXNET.pkg”
  4. 按照安装向导中的说明进行操作,并使用默认选项。

    • 备注:系统可能会提示您输入许可证密钥。 
  5. 当 FLEXNet 安装完成时,重新启动计算机。

原因

此问题可能由不同的情况引起:
  • 干扰 Tableau 文件和目录的第三方工具或系统。
  • FlexNet 许可证数据的损坏问题。
  • 时间计算机备份和移动 Tableau Desktop 图像。
要避免此问题,请与您的 IT 团队合作,确保没有托管的服务或帐户正在修改 Tableau 文件,包括相关的 FlexNet 文件。
 

其他信息

备注:输出 (after running the ls -l /Library/Preferences/FLEXnet\ Publisher/FLEXnet cmd) 中列出的 tableau_xxxxxxx_event.log 和 tableau_xxxxxxx_tsf.data_backup 文件应由遇到问题的用户的本地系统拥有,并且分别具有 -rw-r--r-- 和 -rw-rw-rw- 的权限。如果它们由不同的用户拥有/具有不正确的权限,请尝试手动将其更改回来。 

有关更多信息,请参见在 Mac 上激活时出现错误:“FLEXNet 许可服务不存在”或“函数 flxActAppActivationSend 返回了错误 (0,0,0)”



讨论本文章...反馈论坛
此文章是否已解决问题?