BASE DE CONOCIMIENTO

Error "There was an unexpected error while trying to repair Trusted Storage" al activar o instalar en Mac


Publicado: 13 Jan 2016
Fecha de la última modificación: 09 May 2022

Problema

Al intentar activar Tableau Desktop, es posible que se produzcan los siguientes errores:

Se produjo un error inesperado al intentar reparar el almacenamiento de confianza.

O bien 

Function flxActCommonRepairLocalTrustedStorage returned error (50044, 71013, 19810) (La función flxActCommonRepairLocalTrustedStorage devuelve el error [50044, 71013, 19810])
LM_TS_LOCAL_REPAIR
There was an unexpected error while trying to repair Trusted Storage (Se produjo un error inesperado al intentar reparar el almacenamiento de confianza).


O bien 

Function flxActCommonRepairLocalTrustedStorage returned error (50044, 71013, 27) (La función flxActCommonRepairLocalTrustedStorage devuelve el error [50044, 71013, 27])
LM_TS_LOCAL_REPAIR
There was an unexpected error while trying to repair Trusted Storage (Se produjo un error inesperado al intentar reparar el almacenamiento de confianza).


O bien

ERROR: flxActCommonLicSpcPopulateAllFromTS (50030, 71521,17005)
When trying to review trusted storage using custactutil (Al intentar revisar el almacenamiento de confianza mediante custactutil)
 

Entorno

  • Tableau Desktop
  • Mac OS
  • Software de terceros

Solución

Opción 1: para Tableau Desktop 2019.3 y versiones posteriores

Vuelva a ejecutar el instalador, ya que el paquete de Flexnet no se puede dividir más. 


Opción 2: para todas las versiones de Tableau Desktop

Tenga en cuenta que si utiliza el método siguiente, podría afectar a otras aplicaciones que también se ejecutan con FLEXnet. Póngase en contacto con su equipo de TI antes de continuar.

En el equipo donde está instalado Tableau Desktop, elimine manualmente los archivos de preferencias de FLEXnet de la carpeta Biblioteca. Para encontrar y eliminar los archivos de preferencias de FlexNet, siga estos pasos:
  1. Cierre Tableau Desktop.
  2. Abra Finder
  3. Seleccione Ir > Ir a carpeta  desde la barra de menú de la parte superior de la pantalla
  4. Escriba /Library/Preferences/FLEXnet Publisher/FLEXnet y seleccione Ir
  5. Resalte todos los elementos del directorio y use Cmd + Retroceso para eliminarlos
    • Nota: los archivos también se puden eliminar si se ha seleccionado la opción Engranaje > Mover a la papelera mientras se resaltan los elementos
  6. Reinicie el equipo.
  7. Abra Tableau Desktop y escriba su clave de producto para activarlo, si es necesario. 

Opción 3: para Tableau Desktop 2019.2 y versiones anteriores

En el equipo donde está instalado Tableau Desktop, vuelva a instalar manualmente el paquete FlexNet. Para encontrar e instalar los componentes de obtención de licencias de FlexNet, consulte los siguientes pasos:
  1. En el Finder, haga clic en Aplicaciones.
  2. Mantenga presionada la tecla Control, haga clic en Tableau y, a continuación, seleccione Mostrar contenido del paquete.
  3. Haga doble clic en Contenido, en Instaladores y, finalmente, en Tableau FLEXNET.pkg.
  4. Siga las instrucciones del asistente de instalación y utilice las opciones predeterminadas.

    • Nota: Es posible que se le pida introducir la clave de licencia. 
  5. Cuando se complete la instalación de FLEXNet, reinicie el equipo.

Causa

Este problema puede deberse a diferentes circunstancias:
  • Sistemas o herramientas de terceros que interfieren con los archivos y directorios de Tableau.
  • Problemas de corrupción con los datos de licencia de FlexNet.
  • Copias de seguridad de máquinas de tiempo y transferencia de imágenes de Tableau Desktop.
Para evitar este problema, trabaje con su equipo de TI a fin de asegurarse de que ningún servicio o ninguna cuenta gestionada pueda modificar los archivos de Tableau, incluidos los archivos de FlexNet relevantes.
 

Información adicional

Nota: Los archivos tableau_xxxxxxx_event.log and tableau_xxxxxxx_tsf.data_backup que aparecen en la salida (luego de ejecutar ls -l /Library/Preferences/FLEXnet\ Publisher/FLEXnet cmd) deberían ser propiedad del sistema local del usuario que experimenta el problema y tienen permisos de -rw-r--r-- y -rw-rw-rw-, respectivamente. Si el propietario es un usuario diferente/no tiene los permisos correctos, intente volver a cambiarlos manualmente. 

Para obtener más información, consulte Errores: "El servicio de licencia de FLEXNet no está presente" o "La función flxActAppActivationSend devuelve el error (0,0,0)" al activarlo en Mac



Comente sobre este artículo… Foro de comentarios
¿Fue de ayuda este artículo para resolver el problema?