BASE DE CONOCIMIENTO

Error "There was an unexpected error while trying to repair Trusted Storage" al activar o instalar en un Mac


Publicado: 13 Jan 2016
Fecha de la última modificación: 23 Apr 2020

Problema

Al intentar activar Tableau Desktop tras restaurar desde una copia de seguridad de un equipo temporal o mover Tableau Desktop manualmente desde otra unidad, se produce el siguiente error:

There was an unexpected error while trying to repair Trusted Storage. (Se produjo un error inesperado al intentar reparar el almacenamiento de confianza)

o

Function flxActCommonRepairLocalTrustedStorage returned error (50044, 71013, 19810) (La función flxActCommonRepairLocalTrustedStorage devuelve el error [50044, 71013, 19810])
LM_TS_LOCAL_REPAIR
There was an unexpected error while trying to repair Trusted Storage (Se produjo un error inesperado al intentar reparar el almacenamiento de confianza).


o

Function flxActCommonRepairLocalTrustedStorage returned error (50044, 71013, 27) (La función flxActCommonRepairLocalTrustedStorage devuelve el error [50044, 71013, 27])
LM_TS_LOCAL_REPAIR
There was an unexpected error while trying to repair Trusted Storage (Se produjo un error inesperado al intentar reparar el almacenamiento de confianza).

Entorno

  • Tableau Desktop
  • Mac OS

Solución

Opción 1: para Tableau Desktop 2019.2 y versiones anteriores

En el equipo donde está instalado Tableau Desktop, vuelva a instalar manualmente el paquete FlexNet. Para encontrar e instalar los componentes de obtención de licencias de FlexNet, consulte los siguientes pasos:
  1. En el Finder, haga clic en Aplicaciones.
  2. Mantenga presionada la tecla Control, haga clic en Tableau y, a continuación, seleccione Mostrar contenido del paquete.
  3. Haga doble clic en Contenido, en Instaladores y, finalmente, en Tableau FLEXNET.pkg.
  4. Siga las instrucciones del asistente de instalación y utilice las opciones predeterminadas.
    • Nota: es posible que se le pida introducir la clave de licencia. 
  5. Cuando se complete la instalación de FLEXNet, reinicie el equipo.
 

Opción 2: para Tableau Desktop 2019.3 y versiones posteriores

Vuelva a ejecutar el instalador, ya que el paquete de Flexnet no se puede dividir más. 

 

Opción 3: para todas las versiones de Tableau Desktop

Tenga en cuenta que si utiliza el método siguiente, podría afectar a otras aplicaciones que también se ejecutan con FLEXnet. Póngase en contacto con su equipo de TI antes de continuar.

En el equipo donde está instalado Tableau Desktop, elimine manualmente los archivos de preferencias de FLEXnet de la carpeta Biblioteca. Para encontrar y eliminar los archivos de preferencias de FlexNet, siga estos pasos:
  1. Abra Finder
  2. Seleccione Ir > Ir a carpeta  desde la barra de menú de la parte superior de la pantalla
  3. Escriba /Library/Preferences/FLEXnet Publisher/FLEXnet y seleccione Ir
  4. Resalte todos los elementos del directorio y use Cmd + Retroceso para eliminarlos
    • Nota: los archivos también se puden eliminar si se ha seleccionado la opción Engranaje > Mover a la papelera mientras se resaltan los elementos
  5. Reinicie el equipo
  6. Inicie Tableau Desktop y escriba su clave de producto para activarlo, si es necesario.

    Causa

    Al restaurar Tableau Desktop a partir de una copia de seguridad del equipo temporal o si mueve Tableau Desktop, FlexNET se debe instalar manualmente.
    ¿Fue de ayuda este artículo para resolver el problema?