KNOWLEDGE BASE

Fehler "There was an unexpected error while trying to repair Trusted Storage" beim Aktivieren oder Installieren auf einem Mac


Veröffentlicht: 13 Jan 2016
Zuletzt geändert am: 23 Apr 2020

Problem

Wenn Sie versuchen, Tableau Desktop nach der Wiederherstellung aus einer Time Machine-Sicherung oder nach dem manuellen Verschieben von Tableau Desktop auf ein anderes Laufwerk zu aktivieren, tritt folgender Fehler auf:

There was an unexpected error while trying to repair Trusted Storage. (Beim Versuch, Trusted Storage zu reparieren, ist ein unerwarteter Fehler aufgetreten.)

oder 

Function flxActCommonRepairLocalTrustedStorage returned error (50044, 71013, 19810) . (Funktion flxActCommonRepairLocalTrustedStorage hat einen Fehler zurückgegeben (50044, 71013, 19810) .)
LM_TS_LOCAL_REPAIR
There was an unexpected error while trying to repair Trusted Storage. (Beim Versuch, Trusted Storage zu reparieren, ist ein unerwarteter Fehler aufgetreten.)


oder 

Function flxActCommonRepairLocalTrustedStorage returned error (50044, 71013, 27) (Funktion flxActCommonRepairLocalTrustedStorage gab Fehler (50044, 71013, 27) zurück)
LM_TS_LOCAL_REPAIR
There was an unexpected error while trying to repair Trusted Storage. (Beim Versuch, Trusted Storage zu reparieren, ist ein unerwarteter Fehler aufgetreten.)

Umgebung

  • Tableau Desktop
  • Mac OS

Lösung

Option 1 - Für Tableau Desktop 2019.2 und Vorgängerversionen

Installieren Sie das FlexNet-Paket auf dem Computer noch einmal manuell, auf dem Tableau Desktop ausgeführt wird. Im folgenden Schritt wird erläutert, wie Sie die FlexNet-Lizenzierungskomponenten finden und installieren:
  1. Klicken Sie im Finder auf Anwendungen (Applications).
  2. Halten Sie die Ctrl-Taste gedrückt, klicken Sie auf Tableau, und wählen Sie die Option Paketinhalt anzeigen (Show Package Contents) aus.
  3. Doppelklicken Sie nacheinander auf Inhalt (Contents), auf Installationsprogramme (Installers) und auf Tableau FLEXNET.pkg.
  4. Befolgen Sie die Anweisungen im Installationsassistenten, und übernehmen Sie die Standardeinstellungen.
    • Hinweis: Sie werden möglicherweise zur Eingabe des Lizenzschlüssels aufgefordert. 
  5. Sobald die FLEXNet-Installation abgeschlossen ist, starten Sie den Computer neu.
 

Option 2 - Für Tableau Desktop 2019.3 und spätere Versionen

Führen Sie das Installationsprogramm erneut durch, denn das Flexnet-Paket kann nicht mehr länger als Split bestehen. 

 

Option 3 - Für alle Versionen von Tableau Desktop

Achtung: Über die unten beschriebene Methode kann es zu Auswirkungen auf andere Anwendungen kommen, die ebenfalls mit FLEXnet ausgeführt werden Beraten Sie sich mit Ihrem IT-Team, bevor Sie fortfahren.

Entfernen Sie auf dem Computer, auf dem Tableau Desktop ausgeführt wird, manuell die FLEXnet-Voreinstellungsdateien aus dem Bibliotheksordner. Befolgen Sie zum Suchen und Entfernen der FlexNet-Voreinstellungsdateien die unten beschriebenen Schritte:
  1. Öffnen Sie den Finder.
  2. Wählen Sie in der Menüleiste oben im Bildschirm Gehe zu > Gehe zu Ordner.
  3. Geben Sie /Library/Preferences/FLEXnet Publisher/FLEXnet ein und wählen Sie Gehe zu.
  4. Heben Sie alle Elemente im Verzeichnis hervor und löschen Sie sie über die Tasten CMD + DELETE.
    • Hinweis: Die Dateien können auch gelöscht werden, wenn die Option Zahnradsymbol > In den Papierkorb legen aktiviert wird, während die Elemente hervorgehoben sind.
  5. Starten Sie den Computer neu.
  6. Starten Sie Tableau Desktop und geben Sie bei Bedarf den Produktschlüssel ein, um das Produkt zu aktivieren. 

    Ursache

    Wenn Tableau Desktop aus einer Time Machine-Sicherung wiederhergestellt wird oder Tableau Desktop verschoben wird, muss FlexNET manuell installiert werden.

    Zusätzliche Informationen



    Über diesen Artikel diskutieren... Feedback-Forum
    Hat dieser Artikel das Problem gelöst?