Error: "Firebird Database Error 335544344" When Opening Workbooks After Upgrade
Published: 01 Mar 2017 Last Modified Date: 20 Jul 2023
Issue
When opening a workbook after upgrading Tableau Desktop, the following error might occur:
The custom geocoding folder C:\Program Files\Tableau\Tableau <version>\local\data has errors. The custom geocoding data source C:\Program Files\Tableau\Tableau <version>\local\data\<Geographic Role>.tds contains errors: Firebird database error 335544344: I/O error during "CreateFile (open)" operation for file "GEOCODING.FDB" -Error while trying to open file -The system cannot find the file specified. Unable to connect to the file "GEOCODING.FDB". Check that the file exists and that you have sufficient access privileges for it. ...
Disclaimer: Although we make every effort to ensure links to external websites are accurate, up to date, and relevant, Tableau cannot take responsibility for the accuracy or freshness of pages maintained by external providers. Contact the external site for answers to questions regarding its content.
If the issue persists after repair, perform a clean reinstall of Tableau Desktop:
Uninstall the program.
Navigate to C:/Program Files/Tableau and delete the "Tableau <version>" folder of the version of Tableau Desktop being reinstalled
Install Tableau Desktop as an administrator (by right-clicking the installer file and selecting "Run as administrator")
Cause
This behavior is related to a known issue with ID 741117 which has been corrected in Tableau Desktop 2018.3.
Additional Information
This issue only occurred when installing a new version of Tableau Desktop while the old one was still open. If you ensure all instances of Tableau Desktop are closed before installing a new version of Tableau Desktop 2018.2 or earlier, this issue will not occur.
Tableau Desktop 2018.3 and newer versions will not install while another copy of Tableau Desktop is running.
Thank you for providing your feedback on the effectiveness of the article.