KNOWLEDGE BASE

Error During Tableau Server upgrade: "The primary port for service gateway_0 was already registered on port 80 and cannot be remapped."


Published: 05 Jan 2021
Last Modified Date: 14 Oct 2021

Issue

Tableau Server upgrade fails with the following error:

 "The primary port for service gateway_0 was already registered on port 80 and cannot be remapped."

When this error occurred, you might have already set gateway.port to 80 using "tsm topology set-ports" and might have confirmed this using "tsm configuration get -k gateway.port".
You might be able to find that gateway.port is not configured 80 in the configuration file generated by "tsm settings export -f <file name>".

Environment

  • Tableau Server 2018.1 - 2020.2.9

Resolution

Option 1

Configure gateway.port manually using "tsm configuration set" command:

tsm configuration set -k gateway.port -v 80
tsm pending-changes apply
Then execute upgrade script again.

Option 2 

Obliterate and clean install Tableau Server. In order to prevent this issue in a future identical upgrade, keep the default Gateway port (80) from the previous configuration until the upgrade is complete, where the Gateway Port can changed via the TSM Web UI, and Applying pending-changes. 

Cause

This behavior might be related to a know issue which has been corrected in more recent versions.

 
Did this article resolve the issue?