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Error "DataServiceFailure" Occurs if Tableau Prep is Connected to a Published Data Source and Idle for Several Hours


Published: 05 Jul 2023
Last Modified Date: 10 Jul 2023

Issue

In Tableau Prep Builder, when connected to a published data source from Tableau Server or Tableau Cloud, the below error occurs if Tableau Prep Builder is not operated for several hours:

Can't connect to datasource XXXXX. An error occurred while communicating with Tableau Server
No Tableau Server user found.
DataServiceFailure
There was an error with the data source " ". Verify that the data source is configured correctly.


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Environment

  • Tableau Prep Builder
  • Tableau Server
  • Tableau Cloud

Resolution

If this "DataServiceFailure" error occurs, please click on the data source "Tableau Server" on the left side (see the below image) to sign in again.
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Cause

When using a published data source, if no communication occurs for several hours, the connection to Tableau Server or Tableau Cloud will need to be re-authenticated and is by design.

Additional Information

When you connect to Tableau Cloud, users will need to re-authenticate after not using Tableau Cloud for a period of 2 hours(120 minutes).
Please refer to the Tableau Online Help for Security in the Cloud.

"Tableau Cloud enforces an idle session timeout of 2 hours. ...The idle session timeout value is a system setting that cannot be modified "

When you connect to Tableau Server, users will need to re-authenticate after not using Tableau Cloud for a period of 4 hours(240 minutes).
Please refer to the Tableau Online Help for further information on the idle limit.

You can also change the user Session Timeout in Tableau Server by the below method:
Changing the User Session Timeout
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