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Error "Data Extract Required" Saving Workbook to Tableau Public


Published: 23 Feb 2016
Last Modified Date: 27 Jul 2023

Issue

When working in the Tableau Public Desktop client software, the following error can occur after signing in to the Tableau Public Server:
 
Data Extract Required
The Tableau server you are publishing to does not permit external database connections. Use the Data menu to create an extract for the following data source:
<data-source-name>

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Environment

  • Tableau Public Server
  • Tableau Desktop
  • Live data connection 

Resolution

Please note:

It is not possible to save a workbook locally or create an extract in the Tableau Public Desktop.  It is only possible to publish the workbook to the Tableau Public Server.  This error can occur when working with a live data source in Tableau Public after just signing in to the Tableau Public Server.  The solution is noted in number three below to save the workbook to the Tableau Public Server so an extract can be created.

1. Be sure to have the latest Tableau Public Desktop download when facing errors such as the one described here. 

2. If the Tableau Public Server is not available, a message will display when publishing to the Tableau Public Server that "Updates are in progress".  Review the Tableau website to see a service interruption located on the Tableau Trust site.  Attempt publishing your workbook when the Tableau Public Server is not under maintenance.

3. For a workbook that uses a live connection to a supported data source, when publishing the workbook to the Tableau Public Server, Tableau Public Desktop will create the extract by default.  Close the error window and complete the updates to the workbook.  Publish the workbook to the Tableau Public Server and an extract will be created.  In Tableau Public use File > Save to Tableau Public or Save to Tableau Public As to get an extract created.

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The error received in the Tableau Public Desktop states that it is possible to create an extract using the Data menu but that is not available in the Tableau Public Desktop. The error screenshot has invalid information not applicable to the Public Desktop version. It is not possible to force extract creation in the Tableau Public Desktop.

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After publishing the workbook to the Tableau Public Server, the data shows as an extract in the workbook:

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Please Note: If you have received a workbook from another source and opened the workbook in the Tableau Public Desktop but then received an error trying to publish, it will be necessary to contact the workbook owner to extract the data.  It is not possible to create an extract in the Tableau Public Desktop from a the main toolbar or the Data pane window.

Cause

The Tableau Desktop Public Edition and Tableau Public (web) work with data from Microsoft Excel, multiple text file formats, statistical files, Google Sheets and web data connectors.  It is not possible to save a workbook locally or create an extract manually using Tableau Public Desktop by design.

The error can occur by just signing in to the Tableau Public Server when the data source is live because the Tableau Public Desktop recognizes the data is not extracted.  

Additional Information

For more information on Tableau Public, including how Google Sheets data is refreshed, see the Tableau Public FAQ.

Visit the Tableau Community Forums topic on Tableau Public to raise a question or view information specific to Tableau Public.

See the Tableau Public website for the current status, the FAQ, and to Contact Us.
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