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Error "Connection timed out (0x0000274C/10060) Is the server running on host [... ]and accepting TCP/IP connections on port 8060?" When connecting to Tableau Server's PostgreSQL database from Tableau Desktop


Published: 23 Aug 2019
Last Modified Date: 17 Oct 2019

Issue

When connecting to Tableau Server PostgreSQL database using Tableau Desktop, the following error might occur: 
 
"could not connect to server: Connection timed out (0x0000274C/10060) Is the server running on host "<TableauServerName.com>" (IP address) and accepting TCP/IP connections on port 8060? Unable to connect to the PostgreSQL server "<TableauServerName.com>". Check that the server is running and that you have access privileges to the requested database."

Additionally, it was reported that the tsm data-access repository-access enable --repository-username readonly --repository-password <PASSWORD> command was not completing and the server would need to be rebooted to exit the command.

 

Environment

  • Tableau Server 2019.1
  • Windows Server 2012
  • Tableau Server's internal PostgreSQL repository

Resolution

Work with your IT team to unblock port 8060 on the security appliance for port forwarding with external connections. 

 

Cause

Port 8060 was blocked by a security appliance's port forwarding for public connectors (such as the Tableau Server name in the connection, error message and Powershell command suggested).

Additional Information

The following test was run in Windows Powershell using the Tableau Server name in the Connection window (and in the error):
 
Test-NetConnection -Port 8060 -ComputerName tableau.duravent.com

The result should be True. If it is not, then something is blocking port 8060.


Additionally, run the command from the tsm data-access Tableau Help article to ensure the readonly or tableau users are set up properly to access PostgreSQL repository:

tsm data-access repository-access list [global options]

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