Error Connecting to Teradata Workbooks: "[WSock32 DLL] 10060 WSA E TimedOut: No response received when attempting to connect to the Teradata server Unable to connect to the server"
Published: 16 Nov 2016 Last Modified Date: 08 Jul 2022
Issue
When viewing workbooks connected to Teradata, the following errors occur:
Session Ended by Server
An Unexpected error occurred. If you continue to receive this error please contact your Tableau Server Administrator
[WSock32 DLL] 10060 WSA E TimedOut: No response received when attempting to connect to the Teradata server Unable to connect to the server "<server name>." Check that the server is running and that you have access privileges to the requested database.
Install the latest version of the Teradata driver on the machine running Tableau Desktop and/or Tableau Server. See our Driver Download page for more information.
Cause
Tableau Server cannot reach the Teradata Server.
Additional Information
The error "throw DataSourceException (type=UnableToConnect): [WSock32 DLL] 10060 WSA E TimedOut: No response received when attempting to connect to the Teradata server\n"} will also appear in the Tableau Server VizQL logs. this error comes from the VizQL drivers.