KNOWLEDGE BASE

Error "Communicating with Progress OpenEdge"


Published: 21 Jun 2013
Last Modified Date: 19 Jul 2018

Issue

When you try to connect to Progress OpenEdge, the following error might occur:

An error occurred while communicating with Progress OpenEdge Database
The drivers necessary to connect to this database server are not properly installed.
Database error 0x8004005: [Microsoft][ODBC Driver Manager] Data source name not found and no default driver specified
Unable to connect to the server "<servername>". Check that the server is running and that you have access privileges to the requested database.
Unable to connect to the server. Check that the server is running and that you have access privliges to the requested database.

 
Alternately, there may be no formal error. Rather, the user will see a link at the bottom of the blank Progress OpenEdge connection saying: 
 
"Download and install the drivers, and then connect."

Environment

  • Tableau Desktop
  • Progress OpenEdge
  • Progress OpenEdge 11.2 ODBC Driver and other versions above 11.1

Resolution

Install a supported Progress OpenEdge driver (versions: 10.2b patch 4, 11.0, 11.1).

Note: It may be necessary to uninstall the Progress OpenEdge 11.2 driver (and later versions) prior to installing a supported version.

Cause

The Progress OpenEdge 11.2 driver and later are not supported. Tableau Desktop does not recognize the driver when the driver is installed.
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