BASE DE CONNAISSANCES

Erreur "Échec de connect() : errno = 10061" Connexion à Hadoop Hive


Date de publication : 27 Aug 2013
Date de dernière modification : 30 Jan 2019

Problème

Lorsque vous tentez de vous connecter à une source de données Hortonworks Hadoop Hive, l'une des erreurs suivantes peut se produire : 

[Hortonworks][Hardy] (22) Erreur de ThriftHiveClient : échec de connect() : errno = 10061

ou

[Hortonworks][Hardy] (34) Erreur de Hive : échec de connect() : errno = 10061

Environnement

  • Tableau Desktop 
  • Hortonworks Hadoop Hive

Résolution

Les étapes de résolution des problèmes suivantes sont susceptibles de résoudre le problème :
  1. Suivez les instructions décrites dans Se connecter à vos données dans l'aide de Tableau pour vous assurer que :
    • Les pilotes corrects sont installés.
    • Le port approprié est sélectionné.
    • Le serveur Hive correct (HiveServer ou HiveServer2) est sélectionné.
  2. Redémarrez le serveur Hortonworks Hadoop Hive.
  3. Ajoutez des exceptions aux logiciels de pare-feu et antivirus pour la communication avec le serveur Hive. Pour plus d'informations, consultez Exigences d'accès Internet dans l'aide de Tableau.
  4. Si le problème persiste, contactez le support Hortonworks.

Cause

Vous trouverez ci-dessous une explication des causes possibles de ce problème :

  • Port et/ou service Hive incorrect défini dans la connexion.
  • Problèmes de réseau.
  • Le serveur Hive n'a pas démarré.

 

Cet article vous a-t-il permis de résoudre le problème ?