BASE DE CONOCIMIENTO

Error "connect() failed: errno = 10061" al conectarse a Hadoop Hive


Publicado: 27 Aug 2013
Fecha de la última modificación: 13 Oct 2022

Problema

Cuando intente conectarse a la fuente de datos Hortonworks Hadoop Hive, puede aparecer uno de los siguientes errores:

[Hortonworks][Hardy] (22) Error de ThriftHiveClient: connect() failed: errno = 10061

o

[Hortonworks][Hardy] (34) Error de Hive: connect() failed: errno = 10061

Entorno

  • Tableau Desktop 
  • Hortonworks Hadoop Hive

Solución

Siga estos pasos para intentar solucionar el problema:
  1. Siga las instrucciones descritas en la sección Conectarse a los datos de la ayuda de Tableau para asegurarse de que:
    • Están instalados los controladores correctos.
    • Está seleccionado el puerto correcto.
    • Se ha seleccionado el Servidor Hive (Servidor Hive o Servidor Hive 2) correcto.
  2. Reinicie el servidor Hortonworks Hadoop Hive.
  3. Añada excepciones al firewall y al software de anti-virus para que se comuniquen con el servidor Hive. Para obtener más información, consulte Requisitos de acceso a Internet en la ayuda de Tableau. 
  4. Si el problema continúa, póngase en contacto con la asistencia de Hortonworks.

Causa

A continuación aparecen las posibles causas de este problema:

  • Puerto y/o Servidor Hive incorrecto definido en la conexión.
  • Problemas de red.
  • El servidor Hive no se ha iniciado.

 

¿Fue de ayuda este artículo para resolver el problema?