KNOWLEDGE BASE

Fehler "connect() failed: errno = 10061" beim Herstellen einer Verbindung zu Hadoop Hive


Veröffentlicht: 27 Aug 2013
Zuletzt geändert am: 01 Feb 2019

Problem

Wenn Sie versuchen, eine Verbindung zu einer Hortonworks Hadoop Hive-Datenquelle herzustellen, kann einer der folgenden Fehler auftreten:

[Hortonworks][Hardy] (22) Error from ThriftHiveClient: connect() failed: errno = 10061

oder

[Hortonworks][Hardy] (34) Error from Hive: connect() failed: errno = 10061

Umgebung

  • Tableau Desktop 
  • Hortonworks Hadoop Hive

Lösung

Mithilfe der folgenden Schritte kann das Problem gelöst werden:
  1. Befolgen Sie die Anweisungen in der Tableau-Hilfe unter Eine Verbindung zu Ihren Daten herstellen, um Folgendes sicherzustellen:
    • Die richtigen Treiber sind installiert.
    • Der richtige Port ist ausgewählt.
    • Der richtige Hive-Server (HiveServer oder HiveServer2) ist ausgewählt.
  2. Starten Sie den Hortonworks Hadoop Hive-Server neu.
  3. Fügen Sie der Firewall und dem Virenschutzprogramm Ausnahmen zur Kommunikation mit dem Hive-Server hinzu. Weitere Informationen finden Sie in der Tableau-Hilfe unter Internetzugriffsanforderungen.
  4. Wenn dieses Problem weiterhin auftritt, wenden Sie sich an den Hortonworks-Support.

Ursache

Das Problem kann folgende Ursachen haben:

  • Falscher Port und/oder Hive-Dienst für die Verbindung definiert
  • Netzwerkprobleme
  • Der Hive-Server ist nicht gestartet.

Hat dieser Artikel das Problem gelöst?