KNOWLEDGE BASE

Error: 'com.tableausoftware.tabadmin.security.PermissionsException" and Failed to apply permissions


Published: 03 Dec 2018
Last Modified Date: 07 May 2019

Issue

When using local authentication, a new repository cannot be added to a worker node and the deployment of the coordination service fails. Additionally, the following error might be found in the tabadminagent logs.

[...] ERROR com.tableausoftware.hyper.HyperApp - Failed to apply permissions. com.tableausoftware.tabadmin.security.PermissionsException: com.tableausoftware.tabutil.dll.Exception: Failed LsaLookupNames2 - 1332 

Environment

Tableau Server 2018.2.0-2018.2.4 and 2018.3.0-2018.3.1

Resolution

Option 1

Upgrade to Tableau Server 2018.2.5, 2018.3.2 or a newer version.  Click here for downloads of current and previous versions of Tableau Server: Tableau Server Downloads and Release Notes. For more information on current releases, see Upgrade Tableau Server and Server Upgrade.

Option 2

As a workaround, verify that the Run As User is configured with a full domain and that all nodes have access to this user and then attempt to deploy the coordination service again.

Cause

This behavior is related to a known issue (ID: 833891 ) which has been fixed in a recent release of Tableau Server. 

The LsaLookupNames2 error is related to the initial configuration for Tableau Server using the local account for the Run As User. For a distributed environment, it is required to enter the account including hostname (i.e. clusterone\tableau). If this account is not entered with a hostname, then the Run As User will fail to be found with the above error on the secondary nodes, and then be defaulted to the Network Server account instead.
Did this article resolve the issue?