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"Error code: E19090E0 [q0.Security]Login failed" when connecting Tableau Desktop to Salesforce Marketing Cloud


Published: 16 Jan 2023
Last Modified Date: 16 Jan 2023

Issue

When connecting Tableau Desktop to Salesforce Marketing Cloud data through the native connector, the following error occurs:

Bad connection: Tableau could not connect to the data source.
Error code: E19090E0
[q0.Security]Login faild......
Connector class: cdama_sfmarketingcloud. Versin 21.8272.0

 

Environment

  • Tableau Desktop
  • Windows
  • MacOS
  • Salesforce Marketing Cloud

Resolution

1. Disable MFA. Contact Salesforce Support to change this setting if necessary.
2. Ensure that "enable username and password for Web Services" in Salesforce Marketing Cloud -> Security Settings is enabled.
User-added image

Cause

Multi-factor authentication (MFA) is enabled, but MFA is not supported for Salesforce Marketing Cloud connection by design.
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