KNOWLEDGE BASE

Error Code: B19090E0 Unable to Publish Kyvos Data Source to Tableau Cloud When Using Initial SQL


Published: 12 Aug 2022
Last Modified Date: 12 Aug 2022

Issue

When publishing a Kyvos data source with Initial SQL to Tableau Cloud, the following error occurs:

Initial sql: EXECUTE AS USER = [TableauServerUser] WITH NO REVERT;

Error Code: B19090E0
[Kyvos][Kyvos ODBC](2507) Error from server:0-Given User does not exist in Kyvos. UserName -xxx@xxx
Unable to connect to the Kyvos server "xxx"

Environment

  • Tableau Desktop 
  • Tableau Cloud
  • Kyvos

Resolution

Create the same user in the database to match the username in Tableau Cloud.

Cause

The username returned by Tableau Cloud does not exist in the Kyvos database.

The parameter [TableauServerUser] used in Initial SQL returns the username of the current online user. The Initial SQL will run when a connection is made to the database, thus taking [TableauServerUser] into the database to set the security context.

Note that, unlike Tableau Server, the email address serves as the unique username in Tableau Cloud, which cannot be changed, and [TableauServerUser] will always return the email address.
 
Did this article resolve the issue?